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Introduction to ArcGIS CityEngine

g What is ArcGIS CityEngine

e ArcGIS CityEngine is an advanced 3D city design software for modelling massive,

interactive, and immersive urban environments.

e Itis a stand-alone desktop application created by Esri, and fully supports the Esri file

geodatabase and Esri shapefile format.

e ArcGIS CityEngine can create cities based on real-world geographic information
system (GIS) data.

More information from https.//www.esri.com/en-us/arcqgis/products/arcgis-cityengine/overview
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g Online Sources
1 @ citykngine 2022.0

[ ] Access Tutorial Projects and File Edit Select Layer Terrains Graph Shapes Analysis Search Scripts Window ArcGIS Urban

Examples in CityEngine: o Novosor @ Wetoome X

1. Open CityEngine program 2 3 ° o x

Window ArcGIS Urban Help Download Tutorials and Examples

2. Click Help > Download Tutorials e g A

Python Reference
[] CityEngine Examples ~

and Examples in the main menu. [ oot | .

Qi = < [] Tutorial 01 Essential Skills 2020.0
P ) { [ Tutorial 02 Terrain and Dynarmic City Layouts 2019.1
H H OffiteibopRefaene [ Tutorial 03 Map Control 2019.1
3. After choosin g a tutoria | or Download CityEngine Help (PD) (] Tatoril 04 Imprt Stets 2010.1
(] Tutorial 05 Import Inital Shapes 2019.1
[ Tutorial 06 Basic Shape Grammar 2021.0
What's New [ Tutorial 07 Facade Modeling 2019.1

example, the project is HEREe s

[ Tutorial 09 Advanced Shape Grammar 2019.1

CityEngine Resources

Training
[ Tutorial 10 Python Scripting 2019.1
. Blog [ Tutorial 11 Reporting 2019.1
automanca”y downloaded and dens Tt 12 Scpted feport port 20101
Social Media 5 ,’:“Tu!ovial 13 Facade Wizard 2019.1 .

Show Key Assist Ctrl+Shift+L

added to your CityEngine About Ciyengine Tutorial 01 Essential Skills 2020.0

workspace. N )

Useful link to access free CityEngine tutorials:

https.//doc.arcgis.com/en/cityengine/latest/tutorials/introduction-to-the-cityengine-tutorials.htm
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g Navigating CityEngine

Toolbar

Navigator

©University of Auckland - Do not disseminate without prior written confirmation

——————
=) AUCKLAND

Scenario Bookmarks
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= ‘scene - 30 View x| Vot e g v Rl R Selection Tool X
e (+)
Search for layers, object Q
e Vode o
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> @ Network v Disable Highlight
< tlods )
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Scenes Viewport

(3D View)

inspector X
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Q| types v
e Inspector
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g Navigating CityEngine
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e Click the Tumble/Rotate button (2
1 Tumble or rotate the scene. .
Press Alt+click.

e Click the Pan/Track button
2 Move the view left, right, up, or down. e  Press Alt+click the wheel button.
e  Press the arrow keys.

3 Dolly/zoom the camera toward or away from the point of e  Click the Dolly/Zoom button
interest. e  Press Alt and right-click.

4 Rotate the view from the current camera position. This can help e Click the Look around button [1—]
create bookmarks that 360 VR exports. e Press B+click.
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.
N R ® New =] X
B CityEngine 2022.0
1 [[Fie bt select Layer Terrains Graph Shapes Analysis Search S Select a wizard p—

New... CaieN__ [ Create a CityEngine project folder.

Open... Ccul+0
-

1. Click File > New > CityEngine > o [ope e

Save All Ctrl+Shift+S (£ General
v (2 CityEngine

CityEngine Project to open the Select a e e :

Sign in

= CityEngine Scene

. . Get Map Data... = City Wizard
wizard dialog box.
xport...

Export Models... Cul+E

2. Click Next. -

Import Zipped Project into Workspace...

Import/Link Project Folder into Workspace...
3. Inthe Project name box, type Manage ESR 2

Your_Project_Name.

a. Click Browse to select a folder e oo B Navigator X E

Project folder:

location or Use default location 3 | | | = g @
Project name: | Your_Project Name | " -
* make sure to remember where you saved [SI— Qe

Location: | C\Users\Default\Deskiop | [Bowes ] =2 ESRLIib

1. Click Finish. | 5 [v & YouProjectName

(= assets

. . . . [= data
2. The project is created in the Navigator. & images
= maps
= moZels
4 = rules
[= scenes

L e anee) [ scripts
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g Create a scene J (B 10| @ o .
= @ & D CityEngine Scene

Q [y W | ‘t This wizard creates a new CityEngine scene file.
. . . . LA ’ elcome to
1. Click File > New > CityEngine > project fokdr; [ You,Prfect Namerecenes lorowse.

File Preview

& assets - -
Go Into [ Fite name: [ new_scene.cej | 2 |
(£ data ECE

CityEngine Scene or right-click

(= models

Coordinate System: ‘ ‘ Choose...

the Your_Project_Name folder P e
7 scenes Delete Delete CGA Rule File
and select New > CityEngine e 3 comm—cT

Export...

Scene to open the Select a
Share As. 3

wizard dialog box again. [ ]| o

Properties Alt+Enter

2. In the File name box, type

B3 Navigator X

Your_Scene_Name.cej. Keep the = @& & @ e

[} i aQ
Coordinate System box empty. el Qe

~ 2 Your Project Name

Click Finish. 5 assets —
& data 4 e

(= images

4. The new scene is created under & maps

(= models
the project folder. / i
= new_scene.cej

(= scripts — g
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g Get map data

Select an existing scene

1
2. Click File > Get map data...

3. ‘Your ArcGIS organization’s URL’ > Type “uoa” and Click Continue
4

Sign in with your UPI Please email drh022@ aucklanduni.ac.nz if you have any issue with sign in

'[5 ESRLIib BN CityEngine 2022.0 - new_scene.cej 571 ALCGIS Sign In for CityEngine >
) File Edit Select Layer Terrains Graph Shapes Analysis Search ¢
H .
v = Your_Project Name et S Sign in with @esri
Open... Ctrl+O
=~ assets Save Ctrl+S ArcGIS login v
p Save As...
= data Save All Ctrl+Shift+S | Your ArcGIS organization's URL ~
f i SRS 3 uoa .maps.arcgis.com
=~ images St
5 2 Get Map Data... [ Remember this URL
= maps Import...
= models .
Export Models... Ctrl+E ~
i;_—:' rules Refresh Workspace O O ad o
i Import Zipped Project into Workspace... Privacy
W > scenes Import/Link Project Folder into Workspace...
" Manage ESRLIib...
1 == new_scene.cej Switch Workspace ,
P iot 1 new_scene.cej [Your Project Name/..]
=2 sCnpts )
p Exit Sign me in automatically
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g Get map data (con.) e —

Navigate to the area of interest and set extent.

RIS Bounds
Coordinate System: WGS 1984 Web Mercator (auxiliary sphere)

1. The Get map data dialog 1

0.000 0,000
OpenS 0.000 0.000 §23
Basemap
e Search for an area and Reslon S [
Image size 0x0 Pixels Terms of use

Esri World Elevation

then zoom in or out OR

Get terrain
. Resolution Medium (2k) ~ | 2048
e Pan with the left mouse o s

Open Street Map

button to navigate Dowrloadnetwors
Download footprints
Generate models for downloaded shapes Terms of use
around the map. :
1. Click Set extent. -
oK Cancel

More Information CityEngine Help:
https.//doc.arcgis.com/en/cityengine/2019.0/help/cityengine-help-get-map-data.htm
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g Get map data (con.)

1. Select the basemap resolution.

Note: Recommend to select Medium (2k) for

smooth downloading.
1. Tick Get Terrain to include
elevation data with your map.
2. Add Open Street Map (OSM) data
to your scene.
e Select Download networks for
street data
e Download footprints for building
footprints data.
1. Click OK.

©University of Auckland - Do not disseminate without prior written confirmation
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9 Get Map Data

Navigate to the area of interest and set extent.

Auckland, NZL

o x
Bounds
Coordinate System: WGS 1984 Web Mercator (auiliary sphere)
Width | 2391.842 Height | 1829.711
X-Offset | 19454850.200 Y-Offset | -4418286.749

]
Resolution Medium (2k) v po4s
mage size UABX 1567 Pixel lerms of use

Esri World Elevation

|Get terrain | 2
Resolution Medium (2k) v 2048
Image size 2048x1567 Pixel Terms of use

Open Street Map

Download networks 4] 3
Download footprints
Generate models for downloaded shapes [] Terms of use

Concel
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g Get map data (con.)

1. OSM dialog opens

vl L]

Navigate to the area of interest and set extent.

Bounds

We recommend to tick all the boxes highlighted. i @ e .

1. Click Finish.

File C:\Users\drh\Documents\CityEngine\Default Workspace\GityEngine Test DY | Browse.

Medium (26)

204811807 Pixe. Terms of use

2. The map with terrain, streets, and

Medium (26) ~
204841807 Pixe. Jerms of use

@ oo

f Scene coordinate system is set to WGS 1984 UTM Zone 605

building footprints aligned to the

elevation data is added to your

CityEngine scene.

Selec

7IMap OSM tags. 1
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g Building Generation

© CityEngine 2022.0 - new_scene.cej o
\le‘[d\\ Select Lay:!.;:ﬁr‘v:rvi :W:;':: Analysis Sju;f(:: tﬂpamdﬂw Ar&%i&i\élix\:’: ;w ;;; :w i e ’.:!‘ :V:)' ‘r'*:dy A‘\ . rra—
1. Select all shapes o o o P
. . e 3
and objects in your a
® Terrsin Imagery2 v Mode SR
Street Network [1714 objects, 1714 selec [ v Disable Highlight
Scene. (Drag and - meml!M:bim‘!Mnhﬂcdl B0 - s - -
select OR Control + A)
2. Click Generate
3 Navigator X i > WY
e  This will create EeYace .
il rksp Q| Alltypes A Rules
buildings and street Syt e | [
networks based on the o Bt pms (R
ArcGIS data AND - 2
& scipts 0 v
CityEngine own builtin e
algorithm. = il
v Default Style v
v d Default Style ™
v Default Style ~
v v Default Style ~
v Default Style hd
v acads Default Style v
v Texiure Defautt Style ~
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g Building Generation
» SR @ @ (8) o s AT £ & b BREY T Thoens B3 D D g 4 B ot uon +
= “Scene X €7 3D View RS A RS e R Navigation Track Tool >

Note: e ®
e The heights and ——e . WD

Street Network [1714 objects, 1714 selec [] [ | [v]

“ Footprints [834 objects, 834 selected] [ | | [v]

sizes of the building

footprints are NOT

== Inspector X

0,
100% accurate. e : . @ .

e Thisisdesignedto ... =

A Rules

> &b
~ %3 Your Project Name

help you with s e
& images A Building From Oper: Default Style ~

generating quick, o v
conceptual context S -8 v
and shadow studies e
for your works. e R
v Default Style e

v tic  Default Style W

v Default Style ~
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g Building Generation

) 3D View % SRR R R Navigation Track Tool >

1.  For more realistic

buildings, select an

appropriate style for - BB

Name 87 .
the building footprints T
. Rule File /ESRLIib/rules/B| | Assign...
in the Inspector. sumie ] | Genee selct..

|A Building From Open' GenericMediumTown T

Level Of_Detail 10D1 v
Visualization Options
. ) " Representati listic with facade te ™
A\ Building From Openll‘ GenericMediumTown i Il oarels
fault Styl Transparency ] ~
Default Style
Level_Of _Detail - ) ) GasnopTolérarios g ¥
GenericMediumTown Rule Options
Visualization Options GenericSmallTown Report OSM_Tags x Disabled v
Representation GenericSmallVillage % 1OD1 Parameters  Default Style v
Transparency NewYork
v Default Style N
CleanupTolerance Vancouver
i Visualization Options cade Schemat I v
Rule Options Zurich P v Default Style
Report OSM_Tags Wellington Representation realistic with facade t« G ol Teitine Default Style 0
- - Monaco
. ’ Transparen realistic with facade textures v 10D2 Parameters  Default Style v
W LOD1 Parameters Riomaggiore P <~y . e
CleanupTolerance schematic facades v wade Textures  Defoult Style v
v Facade Textures || Add new style... . solid color
Rule Options v facade Schematic Default Style v
Preview & select styles... white
. Trondd Sobo i Report_OSM_Tags v Boof Texu Default Style 3
.
“/  1OD1 Parameters || ¢ Rule default
— Connect Attribute...
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g Building Height

=X Inspector X

1. Select a specific building -

Name Windsor Towers A

2. Change building height from W
Rule File /ESRIlib/rules/B|  Assign...
B ui Id i n g S etti n g s Start Rule Generate Select...
v a OpenSt  Default Style v
A LOD1 Parameter  Default Style v
Building Settings 2
Eave_Ht 22.2 [v]
Ridge_Ht @
Usage Residential ~
Building_Form extrusion v
flat W
along v
o v
Floor_Ht 37m v
Underground_Ht om v
Min_Ht om v

Visualization Options

OverwiteColor HFFEE v
i v
v acade Textures  Default Style v
v ade Schematic  Default Style v
v of Textures Default Style v
v ] 1 Default Style v
v 2 ures Default Style v
v ade Schematic  Default Style v
v f Default Style v
V' Reports
v Obiject Attributes i
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Introduction to ArcGIS CityEngine

Helpdesk

Architecture Building Level 4, Room 423 (421-423).
drh022@aucklanduni.ac.nz

Opening Hours:
Mon-Fri: 9:30am-4:30pm
We do not open during public holiday

Appointments only during school breaks

drh.nz

For more about T _J[=J=={ £}

O. drh.nz
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